Kali Linuxは、ローリング・リリースのDebianベースのため、同様に日々更新されるパッケージがあったりします。

 

そんなとき、

$sudo apt -y upgrade

を入力したら、以下のような表示がされましたえーん

 

アップグレードパッケージを検出しています... 完了
以下のパッケージは保留されます:
  kali-linux-default kali-linux-headless
アップグレード: 0 個、新規インストール: 0 個、削除: 0 個、保留: 2 個。

 

さて、これはどうすればよいのか調べてみると、以下の手順がヒットしましたので、早速トライしてみました。

 

$sudo apt list --upgradable
一覧表示... 完了
kali-linux-default/kali-rolling 2021.2.1 amd64 [2021.1.8 からアップグレード可]
kali-linux-headless/kali-rolling 2021.2.1 amd64 [2021.1.8 からアップグレード可]

 

 

次に、これらをアップデートしても問題ないかチェック(シュミレーション)を実施します。

$sudo apt-get -s dist-upgrade
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています... 完了        
状態情報を読み取っています... 完了        
アップグレードパッケージを検出しています... 完了
以下のパッケージが新たにインストールされます:
  ffuf firmware-sof-signed powershell-empire python3-altgraph python3-dropbox python3-gevent
  python3-gevent-websocket python3-greenlet python3-iptools python3-m2crypto python3-macholib
  python3-netifaces python3-parameterized python3-pydispatch python3-pyinstaller python3-pyminifier
  python3-pymysql python3-sqlalchemy-utc python3-xlutils python3-zlib-wrapper python3-zope.event starkiller
以下のパッケージはアップグレードされます:
  kali-linux-default kali-linux-headless
アップグレード: 2 個、新規インストール: 22 個、削除: 0 個、保留: 0 個。
Inst ffuf (1.3.1-0kali1 kali-rolling [amd64])
Inst firmware-sof-signed (1.6.1-2 kali-rolling [all])
Inst python3-dropbox (10.10.0-1 kali-rolling [all])
Inst python3-zope.event (4.4-3 kali-rolling [all])
Inst python3-greenlet (0.4.17-1+b1 kali-rolling [amd64])
Inst python3-gevent (20.9.0-2 kali-rolling [amd64])
Inst python3-gevent-websocket (0.10.1-4 kali-rolling [all])
Inst python3-iptools (0.6.1-0kali2 kali-rolling [all])
Inst python3-parameterized (0.7.0-2 kali-rolling [all])
Inst python3-m2crypto (0.37.1-2 kali-rolling [amd64])
Inst python3-altgraph (0.17+ds0-1 kali-rolling [all])
Inst python3-macholib (1.14+ds0-1 kali-rolling [all])
Inst python3-netifaces (0.10.9-0.2+b3 kali-rolling [amd64])
Inst python3-pydispatch (2.0.5-2 kali-rolling [all])
Inst python3-pyinstaller (3.5-0kali2 kali-rolling [all])
Inst python3-pyminifier (2.1-0kali2 kali-rolling [all])
Inst python3-pymysql (0.9.3-2 kali-rolling [all])
Inst python3-sqlalchemy-utc (0.11.0-0kali1 kali-rolling [all])
Inst python3-xlutils (2.0.0-0kali3 kali-rolling [all])
Inst python3-zlib-wrapper (0.1.3-0kali3 kali-rolling [all])
Inst powershell-empire (3.8.2-0kali1 kali-rolling [all])
Inst kali-linux-headless [2021.1.8] (2021.2.1 kali-rolling [amd64])
Inst starkiller (1.7.0-Kali-0kali2 kali-rolling [amd64])
Inst kali-linux-default [2021.1.8] (2021.2.1 kali-rolling [amd64])
Conf ffuf (1.3.1-0kali1 kali-rolling [amd64])
Conf firmware-sof-signed (1.6.1-2 kali-rolling [all])
Conf python3-dropbox (10.10.0-1 kali-rolling [all])
Conf python3-zope.event (4.4-3 kali-rolling [all])
Conf python3-greenlet (0.4.17-1+b1 kali-rolling [amd64])
Conf python3-gevent (20.9.0-2 kali-rolling [amd64])
Conf python3-gevent-websocket (0.10.1-4 kali-rolling [all])
Conf python3-iptools (0.6.1-0kali2 kali-rolling [all])
Conf python3-parameterized (0.7.0-2 kali-rolling [all])
Conf python3-m2crypto (0.37.1-2 kali-rolling [amd64])
Conf python3-altgraph (0.17+ds0-1 kali-rolling [all])
Conf python3-macholib (1.14+ds0-1 kali-rolling [all])
Conf python3-netifaces (0.10.9-0.2+b3 kali-rolling [amd64])
Conf python3-pydispatch (2.0.5-2 kali-rolling [all])
Conf python3-pyinstaller (3.5-0kali2 kali-rolling [all])
Conf python3-pyminifier (2.1-0kali2 kali-rolling [all])
Conf python3-pymysql (0.9.3-2 kali-rolling [all])
Conf python3-sqlalchemy-utc (0.11.0-0kali1 kali-rolling [all])
Conf python3-xlutils (2.0.0-0kali3 kali-rolling [all])
Conf python3-zlib-wrapper (0.1.3-0kali3 kali-rolling [all])
Conf powershell-empire (3.8.2-0kali1 kali-rolling [all])
Conf kali-linux-headless (2021.2.1 kali-rolling [amd64])
Conf starkiller (1.7.0-Kali-0kali2 kali-rolling [amd64])
Conf kali-linux-default (2021.2.1 kali-rolling [amd64])

 

ここでエラーが表示されていないことを確認した後に、以下のコマンドラインを入力しました。

$sudo apt-get dist-upgrade

 

結果、無事にインストールされたことを確認いたしました。

 

Ubuntuでは、このようなことは無かったので、ちょっと調べましたが、今回はあっさりと解決できました。

 

もし、お手元の環境で同様の状況が見られた場合、上記の手順をもとにトライをしてみてもよいかと思います。

 

いやはや、今更ながら勉強になりました爆  笑